Estering


Il blog di Ester Memoli


*****************************************************

La mia rubrica su Techeconomy.it Managed Services


*****************************************************

La mia videointervista su MSN Video


*****************************************************

Colored Glances. Io e i miei colori. Il blog di un hobby colorato.


*****************************************************


*****************************************************

***DotNetHell.it TEAM***

*****************************************************

*****************************************************


Sondaggio
Tenere la vita reale separata da quella online?

Si
No

Mappa

Excel: SE, CERCA.VERT e formattazione condizionale

Ho finito di mettere parzialmente a posto lo sgorbio di cui vi parlavo prima almeno per quanto riguarda le formule e un minimo di formattazione, perché sono davvero ancora all'inizio.

Colgo l'occasione per raccontarvi brevemente com'è composto lo sheet, si sa mai che possa tornare utile a qualcuno.
I dati per ora sono fittizi (Ok, Benino, Male), così come ho eliminato le voci nella prima colonna per un discorso di privacy.

Ciò che si vuole ottenere è:

per ogni utente, in base al Tipo (A, C o S) e in base al voto (da 1 a 10), ognuno dei giudizi per le 4 colonne (Routing, DBMS, Microsoft e LANDesk) deve ottenere un valore "OK" se il voto è maggiore o uguale a quello minimo necessario per il tipo, deve ottenere "Benino" se il voto è minore del minimo necessario per il tipo, ma comunque superiore o uguale al minimo/2, deve ottenere "Male" se il voto è minore del minimo necessario per il tipo e anche inferiore al minimo/2.

(pant pant pant, ce l'ho fatta)

Iniziamo:

I minimi sono indicati in una tabella diversa (denominata "dati"), alla quale la nostra accederà grazie a CERCA.VERT.
Quindi in una colonna di appoggio inserire ad esempio
=CERCA.VERT($C4;dati;2;FALSO)
Questa formula andrà a cercare i voti minimi per ogni materia in base al tipo di utente (A, C o S) e li restituirà nella suddetta colonna.

Quindi:

Nella cella dove si vuole ottenere il giudizio (Ok, Benino, Male) sarà necessario inserire una formula contenente una funzione SE, con un'altra SE nidificata.
=SE(D4>=E4;"OK";SE(D4>=E4/2;"Benino";"Male"))
Questa funzione può essere letta come:
Se il voto è maggiore o uguale al minimo, allora restituisci "OK", altrimenti SE il voto è maggiore o uguale al minimo diviso 2 restituisci "Benino", altrimenti restituisci "Male".

Chiaro no? ;-)

Alla fine basta colorare il testo con la formattazione condizionale, con 3 semplicissime condizioni che assegnano un colore a ognuno dei 3 risultati possibili.
Categoria: Microsoft Office
lunedì, 26 nov 2007 Ore. 23.39
Archivio Posts
Anno 2015

Anno 2013

Anno 2012

Anno 2011

Anno 2010

Anno 2009

Anno 2008

Anno 2007

Anno 2006

Anno 2005
Statistiche
  • Views Home Page: 884.709
  • Views Posts: 3.468.854
  • Views Gallerie: 1.854.058
  • n° Posts: 1.246
  • n° Commenti: 4.073
Copyright © 2002-2007 - Blogs 2.0
dotNetHell.it | Home Page Blogs
ASP.NET 2.0 Windows 2003