Sandro Bizioli


Chi sogna di giorno conosce molte cose che sfuggono a chi sogna soltanto di notte. (E.A.Poe)
Mappa

VB 2008 Express: selezionare la versione di .NET Framework

Visual Studio 2008 permette di selezionare la versione di .Net Framework da utilizzare per la propria applicazione, direttamente dalla finestra di creazione di un nuovo progetto scegliendo tra la 2.0, 3.0 e 3.5.

Tale opzione, come molte altre, non è però presente nella vesione Express, utilizzando come default il Framework 3.5
In ogni caso, è possibile intervenire manualmente direttamente sulle impostazioni avanzate del compilatore.

Una volta creato un nuovo progetto sarà necessario aprire la maschera My Project selezionando la scheda Compilazione ed il pulsante Opzioni di compilazione avanzate....




A questo punto selezionare nella casella "Framework di destinazione" la versione del Framework desiderata.



Inutile ricordare di porre particolare attenzione agli oggetti utilizzati dall'applicazione verificando attentamente se appartengono o meno alla versione del Framework che si desidera utilizzare.
Ad esempio System.Xml.Linq e System.Data.DataSetExtensions andranno tolti.



Un consiglio potrebbe essere quello di crearsi un modello (template) personalizzato per le proprie esigenze.
Vediamo come: una volta creato il nuovo progetto e modificato il Framework di destinazione, selezionare dal menù File la voce Esporta modello...
In questo modo si avrà a disposizione il modello personalizzato evitando di fare tutta la procedura ogni volta che si crea un nuovo progetto.


Categoria: VB.Net
martedì, 10 mar 2009 Ore. 17.16
Statistiche
  • Views Home Page: 104.951
  • Views Posts: 522.315
  • Views Gallerie: 84.594
  • n° Posts: 227
  • n° Commenti: 222
Copyright © 2002-2007 - Blogs 2.0
dotNetHell.it | Home Page Blogs
ASP.NET 2.0 Windows 2003